Back to overview
Degraded

Partial POS connection outage

Apr 04 at 11:01am BST
Affected services
Toggle POS Middleware API

Resolved
Apr 08 at 10:10am BST

After further checks, our initial work on moving the Middleware API resolved all other integrations, other than Zonal and Comtrex, at that time.

These integrations were down between 17:30 03/04/25 and 23:45 03/04/25

Updated
Apr 04 at 07:36pm BST

Heading into the evening and weekend, here is the latest summary in one place:

What's been sorted?

Zonal users Integration is operational. This was down roughly between 17:30 03/04/25 and 16:30 04/04/25.

Comtrex users Integration is operational. This was down roughly between 17:30 03/04/25 and 18:00 04/04/25.

POS Mode is operational. This was down roughly between 17:30 03/04/25 and 21:30 03/04/25.

Degraded service notification remains

We will not mark the solution as resolved until we conclude all integrations that could have been affected are operating as expected. Investigation continues on this.

To recap, what happened in the first place?

One of our hosting providers which houses some of our system had a power outage. This knocked services out, and we have been working to reinstate functionality.

Updated
Apr 04 at 06:08pm BST

Comtrex Sale and redemption of gift cards are now working as expected through Comtrex.

The Degraded flag is still applicable as there may be issues remaining with other integrations using Middleware.

Updated
Apr 04 at 04:53pm BST

We are continuing to work on resolving known Comtrex issues.

While we continue to work on resolving this, it may be pragmatic to put in place communications with contingency plans to your teams for this evening's service.

This page will continue to reflect the status of the issue.

Updated
Apr 04 at 03:53pm BST

Zonal We have made progress and our Zonal integration is now functioning as expected again.

We still have known ongoing issues with Comtrex integration and the team is now working on resolving this.

Created
Apr 04 at 11:01am BST

We are receiving reports of SSL/TLS errors with some POS systems, which are connecting to the Toggle "Middleware" API.

Our engineers are currently investigating this as a priority.