Back to overview
Degraded

Some digital gift emails are not sending

Apr 30 at 04:43pm BST
Affected services
Toggle Shops

Resolved
Apr 30 at 05:49pm BST

This has now been resolved and emails are sending as expected.

Created
Apr 30 at 04:43pm BST

We are experiencing an issue where some gift emails are not being sent to the recipient. We are working on resolving the issue.