Toggle API outage
Resolved
Jul 16 at 01:55am BST
Toggle is now fully back online and operating normally.
We experienced an infrastructure issue related to our AWS Redis caching layer. This was caused by a failover event within our Redis cluster that resulted in misrouting of some API requests. As a result, certain parts of the platform were intermittently unavailable.
We've implemented a fix by provisioning a new Redis cluster and updating our configuration accordingly. All services are now stable.
We're continuing to monitor the platform closely and will be conducting a full post-incident review to prevent similar issues in the future.
Thank you for your patience.
Affected services
Toggle API (legacy)
Toggle Dashboard
Toggle Shops
Toggle POS Middleware API
Toggle POS Mode
Toggle API
Updated
Jul 15 at 11:44pm BST
Our engineers have identified the likely root cause and are working on a resolution.
Affected services
Toggle API (legacy)
Toggle Dashboard
Toggle Shops
Toggle POS Middleware API
Toggle POS Mode
Toggle API
Created
Jul 15 at 10:39pm BST
We are currently investigating an outage on the Toggle API.
This is affecting all connectivity to the Toggle platform.
Affected services
Toggle API (legacy)
Toggle Dashboard
Toggle Shops
Toggle POS Middleware API
Toggle POS Mode
Toggle API